How to Diagnose Missing Videos

How to diagnose videos that seem to be missing from your galleries.

Sometimes TubePress won't show the full number of videos that you think should be displayed in a gallery. For instance, you might have configured TubePress to display 10 videos per page but only 7 are showing up. This article explains how to diagnose and resolve this issue.

Possible Causes

  • Private videos.
  • Region restrictions. Many YouTube videos are restricted to only play in certain regions.
  • Duplicate videos. TubePress ensures that only one copy of a video shows up on each page of a gallery. For instance if you have multiple copies of the same video in a playlist, then TubePress will get rid of the extra copies and only show the first one.

Diagnosis

The first step in diagnosing this issue is to put your site into debug mode. This will dump a huge amount of debugging information to the screen. Don't worry! You don't need to read it all.

Next, hit Ctrl-F in your web browser so that you can search the contents of the page for the phrase Skipping item. If you get any results for your search, you should be able to read the message on why the particular video was skipped. For instance, in the screenshot below you can see in the debug output that TubePress has skipped a private video.

Debug output with skipped video
 

Contact Support

If the above fails and you're still not seeing all the videos you think should be there, please feel free to contact us with a link to a page that demonstrates the issue and we'll be glad to assist.



Last Updated Jul 08, 2016 03:37PM PDT
c65861bf7a72e1a8878bdf73cabbbdbf@tubepress.desk-mail.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete