Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

The request did not specify any referer

Fred Beck
Nov 04, 2016 02:30PM PDT
I am looking at buying tubepress pro version, so I downloaded the free version to see the setup and it is not going well at all. I keep getting this message

"YouTube responded with an error: The request did not specify any referer. Please ensure that the client is sending referer or use the API Console to remove the referer restrictions."

I have followed the instructions for API and have it enabled as step 7 shows. I tried it HTTP and the server way and still get the same message. I have tried with different channels and it just will not load.

Any help would be helpful.


Elisabeth T.  STAFF
Nov 04, 2016 02:45PM PDT

Hi Fred,

Thanks for getting in touch. Could you send us a link to a page demonstrating the issue? We should be able to diagnose this quickly. Feel free to send the link via a ticket 1 if you do not want to submit it publicly. Thanks!


Fred Beck
Nov 04, 2016 02:56PM PDT
this is the page
Elisabeth T.  STAFF
Nov 04, 2016 03:04PM PDT

Thanks for the link. Would you ensure that “None” is selected for your key restriction here 1 (see screenshot 2 also)?



Fred Beck
Nov 04, 2016 03:07PM PDT
Ok it is in none. I have tried that already. In fact a couple of times this time is a charm I hope
Fred Beck
Nov 04, 2016 03:18PM PDT
ok it is working. thanks for your help
Elisabeth T.  STAFF
Nov 04, 2016 03:22PM PDT

Looks like there’s some caching going on, as this page 1, which forces TubePress to skip its internal cache, works normally. Are you using a WordPress caching plugin? If so, it might be caching the TubePress error shown here 2. We can safely say that your key is set up correctly, though it’s not clear to us why you were getting that error earlier.

Finally, the styling of the information below the video thumbnails (title, description, etc.) looks a little off due to some interference from your theme’s CSS. Please let us know if you need any guidance in resolving that issue.



This question has received the maximum number of answers.
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found