Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

All Access w/ Wordpress & Tubepress Pro

jon
Jan 31, 2017 12:28AM PST
After installing tubepress pro+all access, videos and albums are still showing the "Private Video Log in to watch (if you have permission)"

- I downloaded the latest version of tubepress as well as all access pro tonight
- I have installed all access using the instructions, connected the dev site to the vimeo account, created the app and created the access token.
- The access token is showing properly in the vimeo site, as well as on the wordpress site at settings>tubepress>feed (getting the green check mark, and popup verifying that the token creation was successful).
- I have reverified that the videos are in fact uploaded to the correct vimeo account
- I verified the entire setup process several times, and everything seems to be setup exactly as instructed including the callback URLs.
- I deactivating every single additional wordpress plugin, same result
- The them installed is Avada 5.06 on wordpress version 4.7.2
- also tested with the twentyfifteen theme with the same results.
- I have also tested tubepress with vimeo private video on a post / page and neither authenticate properly.
- There are no major modifications to wordpress core files.
- I tested a direct connection to a video, as well as the default [tubepress] shortcode with a source set on the settings>Which videos? page, as well as the album embedding... all seperately. I now have all three embed codes on a single page.

I'm at a loss, please assist.
- The dev page I am working on currently is http://bioresearchinc.hightouch.solutions/smith/ debugging is enabled.
Elisabeth T.  STAFF
Jan 31, 2017 03:54PM PST

Hi Jon,


Thanks for getting in touch and for your detailed explanation. It looks like you need to adjust the privacy settings of your videos on vimeo.com. You’ll need to select “Hide from Vimeo.com” for each video’s privacy settings (see screenshot towards the top of this page 1). It appears you have it set to “Only me” right now, which means that nobody can watch the video unless they’re logged in to your account.


Once you’ve adjusted the privacy settings for each of your private videos, you’ll then need to clear your system cache 2 by visiting this URL 3. This will ensure that TubePress re-contacts Vimeo immediately to see your changes.


That should do it! Give it a try and let us know?


Thanks!


1 http://support.tubepress.com/customer/portal/articles/2285031-add-on-vimeo-all-access


2 http://support.tubepress.com/customer/portal/articles/2048959-the-system-cache


3 http://bioresearchinc.hightouch.solutions/test-biouniversity-subpage/?tubepress_clear_system_cache=true

Jonathan Haggard
Jan 31, 2017 04:13PM PST
I just verified... the one video that I was attempting to use as a sample is / was set as "hide from vimeo"

https://vimeo.com/201558741/settings/privacy

I couldn't attach a screenshot, but here is a link to a screenshot of the video privacy settings:

http://bioresearchinc.hightouch.solutions/wp-content/uploads/2017/01/Capture2.jpg
Elisabeth T.  STAFF
Jan 31, 2017 04:18PM PST

Thanks for including that screenshot. It looks like the second domain you entered under “Where can this video be embedded?” is missing the “inc”; you’ll want to edit that field and you may have to re-clear the cache (http://bioresearchinc.hightouch.solutions/test-biouniversity-subpage/?tubepress_clear_system_cache=true). That should get things working!

This question has received the maximum number of answers.

c65861bf7a72e1a8878bdf73cabbbdbf@tubepress.desk-mail.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete