Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Many Errors in log file cause by tubepress_pro_5_1_0

caleb
Feb 02, 2017 02:05PM PST
2017/02/02 21:52:38 [error] 51509#0: *5254328 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Function name must be a string in /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0/vendor/yahnis-elsts/plugin-update-checker/vendor/Parsedown.php:1412
Stack trace:
#0 /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0/vendor/yahnis-elsts/plugin-update-checker/vendor/Parsedown.php(279): Parsedown->element(Array)
#1 /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0/vendor/yahnis-elsts/plugin-update-checker/vendor/Parsedown.php(39): Parsedown->lines(Array)
#2 /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0/vendor/yahnis-elsts/plugin-update-checker/github-checker.php(262): Parsedown->text('This update for...')
#3 /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0/vendor/yahnis-elsts/plugin-update-checker/github-checker.php(79): PucGitHubChecker_2_2->parseMarkdown('This update for...')
#4 /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0/vendor/yahnis-elsts/plugin-upda" while reading upstream, client: 80.98.118.118, server: mysite.com, request: "GET /wp-admin/update.php?action=install-plugin&plugin=wp-smushit&_wpnonce=f787ae07b3 HTTP/1.0", upstream: "fastcgi://unix:/var/run/php7-fpm-mysitegc.sock:", host: "mysite.com", referrer: "https://mysite.com/wp-admin/plugin-install.php?s=smushit&tab=search&type=term"

This is blocking the installation of other plugins, too.
Elisabeth T.  STAFF
Feb 02, 2017 03:19PM PST

Thanks for getting in touch. TubePress supports PHP 7 from version 5.1.2 and up, so updating 1 to the latest version of TubePress should resolve these errors. Please let us know if there is anything else we can do to assist!


1 http://support.tubepress.com/customer/portal/articles/2278860-enable-automatic-plugin-updates

caleb
Feb 03, 2017 11:36AM PST
I can not enable automatic plugin updates because the settings page gives me a 500 error. It won't load.
Elisabeth T.  STAFF
Feb 03, 2017 12:00PM PST

Performing a manual upgrade should clear things up. You can do this by completing the following steps:


1. Delete the entire /www/mysitegc_487/public/wp-content/plugins/tubepress_pro_5_1_0 directory


2. Perform a fresh install of TubePress Pro 5.1.5 1


That should take care of it, but please let us know if we can do anything else to assist.


1 http://support.tubepress.com/customer/portal/articles/2026334-installation

caleb
Feb 03, 2017 12:24PM PST
This is not resolved. I deleted the directory, manually reinstalled the plugin from the downloads page in my account and the Settings Page for Tubepress still causes a 500 error and I can not access it!
Elisabeth T.  STAFF
Feb 03, 2017 12:30PM PST

So sorry for the continued frustration! Are you willing and able to share both WP and FTP admin access with us? If so, please do so via a private ticket: http://support.tubepress.com/customer/portal/emails/new. We’ll be happy to log in on your behalf and troubleshoot. Please let us know.

caleb
Feb 03, 2017 12:40PM PST
How about an error msg instead...

2017/02/03 20:23:13 [error] 473#0: *53797 FastCGI sent in stderr: "PHP message: PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) in /www/mysite/public/wp-content/plugins/tubepress_pro_5_1_5/src/add-ons/wordpress/classes/tubepress/wordpress/impl/listeners/options/AcceptableValuesListener.php on line 96
Elisabeth T.  STAFF
Feb 03, 2017 12:48PM PST

Typically this error means that your site is trying to load several plugins, and TubePress is simply “the straw that broke the camel’s back.” This article 1 explains some techniques you might try, but we’d recommend contacting your host as they’ll be able to raise your site’s memory limit.


1 https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/

Elisabeth T.  STAFF
Feb 03, 2017 01:12PM PST

Without being able to see the problem firsthand, what’s likely happening is that during TubePress activation your web server’s memory limit is exhausted. You will need to either:


1. Disable some plugins to free up memory, then activate TubePress. You should then be able to reactivate any plugins that you disabled. After activation, TubePress consumes a very small amount of memory, but activation is computationally expensive.


or


2. Ask your web host to increase your PHP memory limit.

This question has received the maximum number of answers.

c65861bf7a72e1a8878bdf73cabbbdbf@tubepress.desk-mail.com
http://assets1.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete